If you're having trouble installing the new Outlook Add-in, please check the following:

Outlook 365/2019 and Exchange Online/2016 are the minimum versions that support all the features we need for the new Outlook Add-in – please confirm if this is what you are using.

Do you have the one-time purchase version of Outlook 2016, or Outlook 365 that's still using the Outlook 2016 UI? You can probably check in the File > Office Account menu.

You can also open the dev tools and run this in the console: Office.context.requirements.isSetSupported('Mailbox', '1.5')

This should print true if your Outlook client supports requirement set 1.5 (the minimum version we require), or false if it doesn't.

Did this answer your question?